Если у вас технический вопрос

Материал из wiki.drweb.com
Перейти к: навигация, поиск

Для решения возникающих затруднений на форуме или при обращении в службу технической поддержки, у вас могут запросить различную информацию. В этой статье вы найдёте советы где, что и как называется и находится.

Помните: кроме вас, никто не видит того, что видите Вы на экране монитора. Поэтому чем полнее и точнее Вы опишете проблему, тем быстрее можете рассчитывать на ее решение. При необходимости приложите скриншоты (снимки экрана). Не надо говорить "у меня та же ерунда", лучше прочитайте тему, посмотрите, что требовалось от топикстартера (инициатор темы) и приложите логи/скриншоты/комментарии.

Немного терминологии

  • Лог - он же отчет - текстовой файл (с расширением log) отчета работы компонента антивируса. Где искать: Пуск->Программы (Все программы)->Dr.Web->Отчёты или %USERPROFILE%\DoctorWeb\ , где %USERPROFILE%\ папка профиля пользователя Windows
  • Билд - версия сборки компонента. Может быть в виде a.bb.c.ddddd, где a - мажорная версия, b - минорная, c - порядковый номер выхода компонента после релиза (c = 0 - релиз), ddddd - дата/время выпуска этого модуля в формате MMDDN, где DD , MM - день и месяц соответственно, N - порядковый номер билда. В контекстном меню спайдерГарда выберите пункт "О программе..." и в открывшемся окне найдите требуемое. Где искать: Правой кнопкой мыши по иконке SpIDer Guard (паучок в в области уведомлений рядом с часами) в появившемся меню пункт "О программе..." или GUI-сканер меню "Справка" -> "О программе..."

Если вопрос по GUI-сканеру

(сканер с графическим интерфейсом пользователя)

  • Включить полную детализацию логов сканера: на вкладке "Отчет" убедиться, что отмечено "Вести файл отчета", и установить "Проверяемые объекты", "Имена упаковщиков", "Имена архиваторов" и "Статистика".
  • Приложить лог, предварительно убрав из него информацию о ключе.

Если вопрос по спайдеру

(SpIDer Guard® -- монитор антивируса)

  • Включить полную детализацию логов спайдера: на вкладке "Отчет" убедиться, что отмечено "Вести файл отчета", и установить "Проверяемые объекты", "Имена упаковщиков" и "Содержимое архивов". Здесь же полезно будет увеличить размер файла отчета до 3 - 4 мегабайт.
  • Приложить лог, предварительно убрав из него информацию о ключе.

Возможно прийдется изменить настройки Spider Guard используя не документированные функции

Если возник вопрос по обновлению

(утилита обновления с графическим интерфейсом)

  • Для получения полного лога обновления следует запустить файл drwebupw.exe из каталога программы DrWeb и установить флажок "Вести подробный отчет".После запуска "обновлялки" лог будет сохранен в каталоге пользователя с именем drwebupw.log

(Где искать: Пуск->Программы (Все программы)->Dr.Web->Отчёты или %USERPROFILE%\DoctorWeb\ , где %USERPROFILE%\ папка профиля пользователя Windows)
При обыкновенном запуске обновления(без указания "Вести подробный отчет",или же из меню Спайдера или Сканера) разработчики не смогут получить более детальный отчет.

Если в процессе работы компьютер самостоятельно перезагружается

Возможно, вы получаете синий экран смерти, так называемый BSOD. Отключите автоматическую перезагрузку при отказе системы: "Мой компьютер" -> "Свойства" -> "Дополнительно" -> "Загрузка и восстановление" -> "Параметры": снять отметку "Выполнить автоматическую перезагрузку". Также выбрать "Дамп памяти ядра". Если в процессе работы система упадет в BSOD, найдите в каталоге %windir%\minidump\ , (где %windir% каталог куда установлена операционная система, обычно "Windows"), файл вида MiniMMDDYY-NN.dmp, где DD , MM и YY - сегодняшний день, месяц и год соответственно, NN - порядковый номер файла дампа. Скорее всего, он там будет не один.

Нужный файл присоедините к сообщению на форуме(для уменьшения размера файла воспользуйтесь архиватором,например 7-Zip или WinRar).

Если размер файла превышает 10 Мб,то следует данный файл разместить на любом публичном файлообменном сервере(например iFolder или Народ Диск)

Внимание: не размещайте на публичных серверах данные, содержащие коммерческую тайну, личные данные, государственную тайну! Возможно, потребуется обратиться в CTO (служба технической поддержки пользователей) с дампом памяти ядра - %windir%\memory.dmp (его размер может достигать нескольких десятков мегабайт).

Как сделать снимок экрана (скриншот)

Для того,чтобы сделать скриншот-необходимо нажать клавишу на клавиатуре PrtSc(PrintScreen). После нажатия этой клавиши в буфер обмена скопируется содержимое экрана, включающее в себя все видимые на мониторе обьекты. Далее для сохранения полученого скриншота необходимо запустить графический редактор Paint (Пуск-Все программы-Стандартные-Paint). После чего в меню Paint следует выбрать пункт Правка->Вставить. В рабочей области программы Paint появится снимок экрана, для его отправки сохраните его: Файл->Сохранить как, введите любое имя, расширение файла рекомендуется выбрать *.PNG. Нажмите ОК. Скриншот готов.


Полезные утилиты

Инструкции по использованию утилит вы получите на форуме или в СТО.