Файл hosts и Dr.Web

Материал из wiki.drweb.com
Перейти к: навигация, поиск

Файл hosts и Dr.Web

Если Вы используете измененный файл hosts, то антивирус после установки обнаружит в нем угрозу DFH.HOSTS.corrupted и восстановит файл в исходное для данной ОС состояние. Чтобы этого избежать необходимо внести файл в исключения для SpIDer Guard и Сканера, чтобы они не проверяли файл на предмет модификации. Кроме Сканера и SpIDer Guard файл защищен от изменения Превентивной защитой. Перед редактированием файла необходимо разрешить соответствующее действие в настройках антивируса. А после редактирования вернуть значение обратно.

Для выполнения этих действий необходимо сделать следующее:

Открытие доступа к файлу hosts

  • Щёлкнуть правой кнопкой мыши по значку Dr.Web в области уведомлений, в появившемся меню выбрать Инструменты->Настройки->Основные->Превентивная защита
  • В открывшемся окне нажать кнопку Пользовательский
Hosts 1.png
  • В следующем окне отметить флажком вариант Разрешать в строке HOSTS файл и нажать Ok
Hosts 2.png

Добавление файла hosts в список исключений SpIDer Guard

  • Перейти на вкладку SpIDer Guard->Исключения и нажать Обзор
Hosts 3.png
  • В открывшемся окне укажите HOSTS файл (путь: C:\WINDOWS\system32\drivers\etc, где C: — диск, на котором установлена операционная система) и нажмите Ok.
Hosts 4.png
  • Нажмите Добавить, чтобы подтвердить исключение, а затем Ok, чтобы закрыть окно настроек.
Hosts 5.png

Добавление файла hosts в список исключений сканера

  • Щёлкните правой кнопкой мыши по значку Dr.Web в области уведомлений и выберите пункт Сканер. В открывшемся окне нажмите F9 или воспользуйтесь главным меню сканера, открыв Настройки->Изменить настройки.
Hosts 6.png
  • Щёлкните левой кнопкой мыши в строке Список исключаемых путей и введите C:\WINDOWS\system32\drivers\etc, после чего нажмите Добавить. При этом в список исключений добавится вся папка с указанным адресом.
  • Для включения в список только одно файла, щёлкните левой кнопкой мыши по кнопке с многоточием напротив строки Список исключаемых файлов и в открывшемся окне файл, который не требует проверки сканером. Нажмите Добавить.
  • Для завершения работы с настройками нажмите Применить, а затем Ок